[phylocom-user] phylocom-user Digest, Vol 2, Issue 3

Jenny Read jenny.read at sci.monash.edu.au
Tue Aug 19 15:25:49 PDT 2008


Hi Steve,

Thankyou for replying so quickly.  I removed the outer set of brackets 
and it worked perfectly.

Many thanks!!!

Kind regards,
Jenny.

Steve Kembel wrote:

> Hi Juan, Jenny,
>
> OK, so if I understand you correctly, Juan, your problem is not  
> actually that the sampleprune function itself is giving a NA error,  
> it's that the trees you generate with sampleprune give you NA values  
> when you run aot?
>
> I suspect the problem you're both having is due to zero-length  
> branches in your tree. If there are branches of length zero, when you  
> run aot the standardized contrast at each node is calculated by  
> dividing the raw contrast by the branch length, which is a division 
> by  zero error. And since the measure of signal is based on the  
> standardized contrasts, you're also getting NA's in the aotf signal  
> output.
>
> There are two ways zero-length branches can come about. One is easy 
> to  fix - if there are any branches of length 0.00 in the tree file,  
> change that to some small non-zero value like 0.001. Consider  
> collapsing zero length or very short branches to polytomies using the  
> ape package in R or similar.
>
> The second is a bit trickier and is caused by missing branch lengths  
> in the tree. If there are any nodes with no branch length listed in  
> the phylo file, phylocom assumes the branch length on that node is  
> zero. The most common way for this problem to appear is when your 
> tree  has a 'tail' - an outer set of parentheses with no branch 
> length  listed. The way to fix this is either to remove the tail, 
> which in a  Newick tree string is the outermost set of parentheses, or 
> to add some  small non-zero branch length to the tail. Look at your 
> phylo file. If  it looks like something like this:
> (((A:3,B:3):7,C:10):5);
> ...the outermost set of parentheses with no ":" after it is the tail.  
> Delete those parentheses and your aot analyses should work with no 
> NAs  in the output. So after deleting the tail your tree would now 
> look  like this:
> ((A:3,B:3):7,C:10):5;
>
> Cheers,
> Steve
>
> On Aug 19, 2008, at 11:03 AM, Juan Pablo Gomez Echeverri wrote:
>
>> Hi
>>
>> I am having the same problem as you are.  I have tried with several  
>> phylogeny and traits files but the only way it worked for me was to  
>> use the exact output of the phylogeny form RAxML without prunning  
>> the phylogeny to the community list.  I am trying to solve this  
>> problem too.  Please let me know if you figure something out. I don 
>> ´t know if it is a problem with branch length format or something  
>> like that.
>>
>>>
>>> From: Jenny Read <jenny.read at sci.monash.edu.au>
>>> Subject: [phylocom-user] aot problem
>>> To: phylocom-user at lists.phylodiversity.net
>>> Message-ID: <48A9F76C.8080700 at sci.monash.edu.au>
>>> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>>>
>>> Hi,
>>>
>>> We are having a problem getting AOT to work (using Windows) in  
>>> Phylocom
>>> v. 4.  The output gives the numbers of traits, taxa, contrasts, but  
>>> does
>>> not give the VarCn or PicR ('NaN' is given).  I have no trouble  
>>> getting
>>> the example files to work, so I assume the problem is something to do
>>> with my file format (saved as text, tab-delimited, then renamed  
>>> without
>>> the extension).  We have tried quite a few variations on file
>>> formatting, but with no luck.  Can anyone suggest what we are doing
>>> wrong please ?
>>>
>>> Many thanks,
>>> Jenny.
>>>
>>> ***
>>
>>
>> Juan Pablo Gomez
>




More information about the phylocom-user mailing list