[phylocom-user] Phylomatic memory issues w/mega-tree...

melissa.whitman at huskers.unl.edu melissa.whitman at huskers.unl.edu
Wed Dec 4 11:38:00 PST 2013


Hi Cam (and associated phylo folks),

I am having issues with creating a tree in phylomatic and based on prior posts it sounds like a memory issue with the program. I am trying to build a tree with 18,000 tips, ideally based on the Smith 2011 tree (includes more orchid and Rhododendron species). However I am encountering a run-time error that Gustavo mentioned a while back. The tree also doesn't work on the Phylomatic online site due to size issues (however a pruned back genera-only version works with R20120829.new).

I tried fixing the problem using the code from the prior text w/Gustavo (swapping Fy2newRec(Prune(P, keep));) in a phylomatic.c file using the program Notepad++. I then used the Unix-like program for Windows Cygwin (with the Devel group package install) to run the $make command without much luck. I have never used Unix before so I am guessing the issue is what to do when writing "$make...". I managed to get as far as working in the right directory, but not beyond that (I can see the phylomatic.c file under $ls). Is there a specific command to write after $make? I have tried various phrasing and tend to get missing separator errors, syntax errors, or unexpected token errors.

Any advice on running the $make hack, or is there an alternate version of Phylomatic (or R script equivalent) that might work without the memory glitch?

Thanks a bunch for any advice.

- Melissa

University of Nebraska
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.phylodiversity.net/pipermail/phylocom-user-phylodiversity.net/attachments/20131204/11cff362/attachment-0001.htm>


More information about the phylocom-user mailing list