[phylocom-user] Phylomatic memory issues w/mega-tree...

Steven Kembel steve.kembel at gmail.com
Wed Dec 4 11:53:05 PST 2013


Hi Melissa,

First, the command you should be running is just "make" - no quotes, no dollar sign. In Cam's example the $ indicates the command prompt, you wouldn't actually type "$make".

Second, if you are typing make at the command line from within the directory with the modified .c files plus the file called Makefile, and nothing happens, or you're getting an error about file not found or something similar, you may need to install the make program itself. I am not sure if it comes pre-installed when you install Cygwin but if there is a configuration or installation tool with Cygwin, try looking in that for the option to install make. Similarly, using the make command assumes you have a C compiler installed - if you type gcc at the command line, does anything happen? If not, you'll need to install that as well.

Third, if you've done the previous two steps, it sounds like there could be an error in your Makefile or the modified .c files. Can you send the modified files to the list, as well as detailed output including all the error messages you get and the contents of the directory from which you're running make (list of the files present).

Best regards,
Steve

Le 2013-12-04 à 14:38, melissa.whitman at huskers.unl.edu a écrit :

> Hi Cam (and associated phylo folks),
> 
> I am having issues with creating a tree in phylomatic and based on prior posts it sounds like a memory issue with the program. I am trying to build a tree with 18,000 tips, ideally based on the Smith 2011 tree (includes more orchid and Rhododendron species). However I am encountering a run-time error that Gustavo mentioned a while back. The tree also doesn't work on the Phylomatic online site due to size issues (however a pruned back genera-only version works with R20120829.new). 
> 
> I tried fixing the problem using the code from the prior text w/Gustavo (swapping Fy2newRec(Prune(P, keep));) in a phylomatic.c file using the program Notepad++. I then used the Unix-like program for Windows Cygwin (with the Devel group package install) to run the $make command without much luck. I have never used Unix before so I am guessing the issue is what to do when writing "$make...". I managed to get as far as working in the right directory, but not beyond that (I can see the phylomatic.c file under $ls). Is there a specific command to write after $make? I have tried various phrasing and tend to get missing separator errors, syntax errors, or unexpected token errors. 
> 
> Any advice on running the $make hack, or is there an alternate version of Phylomatic (or R script equivalent) that might work without the memory glitch? 
> 
> Thanks a bunch for any advice. 
> 
> - Melissa
> 
> University of Nebraska
> _______________________________________________
> phylocom-user mailing list
> phylocom-user at lists.phylodiversity.net
> http://lists.phylodiversity.net/listinfo.cgi/phylocom-user-phylodiversity.net

-- 
Steven Kembel
Professeur régulier / Assistant Professor
Département des sciences biologiques
Université du Québec à Montréal
+1 (514) 987-3000 poste 5855 
http://www.phylodiversity.net/skembel/




More information about the phylocom-user mailing list