[phylocom-user] Phylomatic memory issues w/mega-tree...

melissa.whitman at huskers.unl.edu melissa.whitman at huskers.unl.edu
Mon Dec 16 09:59:31 PST 2013


Hi Cam and Steve,

Thanks for the feedback. I will try the code again. I ran the src and the make command but I am still encountering a few glitches (missing cygwin1.dll is the most recent issue when I click the phyomatic.exe file) that appear to be Cygwin and Windows related. Over the past few days I have been troubleshooting Cygwin issues (re-installing libraries and packages, converting space to tab, etc...) without much luck. I had a friend try the modified code make command with Linux and there were no problems, except for the script to change .fy to nex and trying to make a version that would work with Windows 64 bit. I will try again, if it doesn't work I think I may try the Umbutu on a flashdrive method....

Best wishes,

Melissa
_______________________________________
From: Cam Webb <cwebb at oeb.harvard.edu>
Sent: Monday, December 16, 2013 12:19 AM
To: melissa.whitman at huskers.unl.edu
Cc: Steven Kembel; phylocom-user at lists.phylodiversity.net
Subject: Re: [phylocom-user] Phylomatic memory issues w/mega-tree...

Hi Melissa,

Apologies for the delay adding to this thread.  In case you have not
managed to get the hack to compile, it is already in the github repo:

  https://github.com/phylocom/phylocom

Just get the ZIP archive (bottom right), unzip, `cd src/` and type
`make`.

Best,

Cam




> Hi Melissa,
> You are missing several other files that are necessary, including
> phylomatic.h and the Makefile itself.
> I suggest you copy your updated phylomatic.c file into the directory
> /src included with phylocom. This will overwrite the old phylomatic.c,
> which is OK. The /src directory contains the other files that are
> needed to successfully compile phylomatic. Then go to that directory
> and type make. That will compile the program and will use the updated
> phylomatic.c file. The result will be a new file called phylomatic or
> phylomatic.exe that you can run and should address the memory issues.
> -Steve
> Le 2013-12-04 à 15:55, melissa.whitman at huskers.unl.edu a écrit :
>
>> Hi Steve,
>>
>> I double checked and re-installed the package for Cygwin that has
>> make and gcc, hopefully everything worked (it looked like the gcc
>> package was an older edition than the main package).
>>
>> The code (and command prompt $) looks a bit like this:
>> -------------------------------------------------------------------------------
>> Melissa at BigSquid~
>> $ cd c:/phylocom/phylomatic_hack
>>
>> Melissa at BigSquid /cygdrive/c/phylocom/phylomatic_hack
>> $ls
>> phylomatic.c
>>
>> Melissa at BigSquid /cygdrive/c/phylocom/phylomatic_hack
>> $gcc
>> phylomatic.c:47:22: fatal error: phylocom.h: No such file or directory
>> #include "phylocom.h"
>>                      ^
>> compilation terminated.
>>
>> Melissa at BigSquid /cygdrive/c/phylocom/phylomatic_hack
>> $make
>> make: *** No targets specified and no makefile found.  Stop.
>>
>> Melissa at BigSquid /cygdrive/c/phylocom/phylomatic_hack
>> $make phylomatic.c
>> make: Nothing to be done for 'phylomatic.c'.
>> ---------------------------------------------------------------------------------
>> Attached is a copy of the phylocom.c (modified) file
>>
>> Hopefully this makes sense. Any advice would be wonderful.
>>
>> Best wishes,
>>
>> Melissa
>> ________________________________________
>> From: Steven Kembel <steve.kembel at gmail.com>
>> Sent: Wednesday, December 4, 2013 1:53 PM
>> To: melissa.whitman at huskers.unl.edu
>> Cc: phylocom-user at lists.phylodiversity.net
>> Subject: Re: [phylocom-user] Phylomatic memory issues w/mega-tree...
>>
>> Hi Melissa,
>>
>> First, the command you should be running is just "make" - no quotes,
>> no dollar sign. In Cam's example the $ indicates the command prompt,
>> you wouldn't actually type "$make".
>>
>> Second, if you are typing make at the command line from within the
>> directory with the modified .c files plus the file called Makefile,
>> and nothing happens, or you're getting an error about file not found
>> or something similar, you may need to install the make program
>> itself. I am not sure if it comes pre-installed when you install
>> Cygwin but if there is a configuration or installation tool with
>> Cygwin, try looking in that for the option to install
>> make. Similarly, using the make command assumes you have a C
>> compiler installed - if you type gcc at the command line, does
>> anything happen? If not, you'll need to install that as well.
>>
>> Third, if you've done the previous two steps, it sounds like there
>> could be an error in your Makefile or the modified .c files. Can you
>> send the modified files to the list, as well as detailed output
>> including all the error messages you get and the contents of the
>> directory from which you're running make (list of the files
>> present).
>>
>> Best regards,
>> Steve
>>
>> Le 2013-12-04 à 14:38, melissa.whitman at huskers.unl.edu a écrit :
>>
>>> Hi Cam (and associated phylo folks),
>>>
>>> I am having issues with creating a tree in phylomatic and based on
>>> prior posts it sounds like a memory issue with the program. I am
>>> trying to build a tree with 18,000 tips, ideally based on the Smith
>>> 2011 tree (includes more orchid and Rhododendron species). However
>>> I am encountering a run-time error that Gustavo mentioned a while
>>> back. The tree also doesn't work on the Phylomatic online site due
>>> to size issues (however a pruned back genera-only version works
>>> with R20120829.new).
>>>
>>> I tried fixing the problem using the code from the prior text
>>> w/Gustavo (swapping Fy2newRec(Prune(P, keep));) in a phylomatic.c
>>> file using the program Notepad++. I then used the Unix-like program
>>> for Windows Cygwin (with the Devel group package install) to run
>>> the $make command without much luck. I have never used Unix before
>>> so I am guessing the issue is what to do when writing "$make...". I
>>> managed to get as far as working in the right directory, but not
>>> beyond that (I can see the phylomatic.c file under $ls). Is there a
>>> specific command to write after $make? I have tried various
>>> phrasing and tend to get missing separator errors, syntax errors,
>>> or unexpected token errors.
>>>
>>> Any advice on running the $make hack, or is there an alternate
>>> version of Phylomatic (or R script equivalent) that might work
>>> without the memory glitch?
>>>
>>> Thanks a bunch for any advice.
>>>
>>> - Melissa
>>>
>>> University of Nebraska
>>> _______________________________________________
>>> phylocom-user mailing list
>>> phylocom-user at lists.phylodiversity.net
>>> http://lists.phylodiversity.net/listinfo.cgi/phylocom-user-phylodiversity.net
>>
>> --
>> Steven Kembel
>> Professeur régulier / Assistant Professor
>> Département des sciences biologiques
>> Université du Québec à Montréal
>> +1 (514) 987-3000 poste 5855
>> http://www.phylodiversity.net/skembel/
>>
>> <phylomatic.c>



More information about the phylocom-user mailing list